Zamiana numeru miesiąca na jego nazwę i daty na dzień tygodnia

W Excelu istnieje niepozorna funkcja o nazwie TEKST. Zamienia ona liczbę na tekst w zdefiniowanym przez nas formacie. Załóżmy, że w kolumnie A mamy wpisane numery miesięcy (np 1, 2, 3 itp. a do 12). Aby w kolumnie obok zamiast 1 wyświetliła się nazwa miesiąca, czyli styczeń należy użyć takiej oto funkcji:

=TEKST(DATA(2019;A2;1); „mmmm”)

Jeśli z kolei mamy w danej komórce wpisaną datę i chcemy poznać dzień tygodnia to użyjemy taką oto funkcję:

=TEKST(A2; „dddd”)

Swoją drogą jest to dość ciekawa sprawa, gdyż można się dowiedzieć np. w jaki dzień tygodnia się urodziłeś (niestety, ale Excel obsługuje daty od 01.01.1900 więc nie dowiesz się, w jaki dzień tygodnia odbyła się bitwa pod Grunwaldem).

Ten wpis został opublikowany w kategorii sztuczki i oznaczony tagami , , . Dodaj zakładkę do bezpośredniego odnośnika.

2 odpowiedzi na „Zamiana numeru miesiąca na jego nazwę i daty na dzień tygodnia

  1. Marcin pisze:

    W ramach uzupełnienia mogłeś dodać link do stroniy microsoft’u gdzie jest artykuł o funkcji tekst:
    https://support.office.com/pl-pl/article/tekst-funkcja-20d5ac4d-7b94-49fd-bb38-93d29371225c

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

This site uses Akismet to reduce spam. Learn how your comment data is processed.