Łączenie funkcji LICZ.JEŻELI z innymi funkcjami

Jeśli nie wiesz, jak działa funkcja LICZ.JEŻELI, to najpierw zapoznaj się z notką: Funkcja LICZ.JEŻELI. Rozpatrzmy taki oto prosty przykład

Otóż mamy prostą listę pracowników wraz z ich pensjami. Chcemy policzyć ilu mamy pracowników, których pensje są niższe niż średnia zarobków wszystkich pracowników.

W tym celu należy policzyć najpierw jaka jest średnia zarobków. W tym celu mogę użyć funkcji o nazwie ŚREDNIA:

=ŚREDNIA(B2:B7)

Funkcja ta zwróci wynik 3500. Następnie mogę użyć funkcji LICZ.JEŻELI:

=LICZ.JEŻELI(B2:B7, "<3500")

To rozwiązanie ma jednak pewną wadę: gdy zmienię jakiemuś pracownikowi pensję, to wtedy będzie inna średnia zarobków i będę zmuszony ręcznie dokonać korekty w funkcji LICZ.JEŻELI. Natomiast nic nie stoi na przeszkodzie, aby drugi parametr funkcji zawierał łączenie ciągu znaków: "<" oraz wartości zwróconej przez funkcję ŚREDNIA. W Excelu, aby połączyć ze sobą 2 ciągi znaków używamy symbolu &. Przykładowo taka oto formuła:

=A1&A2 

zwróci nam ciąg znaków: NazwiskoPensja.

Tak więc nasza funkcja zwracająca liczbę pracowników z zarobkami poniżej średniej będzie miała następującą postać:

=LICZ.JEŻELI(B2:B7; "<"&ŚREDNIA(B2:B7))

Jako drugi parametr funkcji LICZ.JEŻELI (kryterium) Excel policzy średnią (wynosi ona 3500) i ten wynik połączy wraz z symbolem < w efekcie jako drugi parametr zostanie podstawiony ciąg znaków "<3500"

Wskazówka: ten trik działa też z innymi funkcjami takimi jak np. SUMA.JEŻELI, ŚREDNIA.JEŻELI, LICZ.WARUNKI.

Ten wpis został opublikowany w kategorii funkcje i oznaczony tagami , , . Dodaj zakładkę do bezpośredniego odnośnika.

1 odpowiedź na Łączenie funkcji LICZ.JEŻELI z innymi funkcjami

  1. Kamila pisze:

    Znam lepsze zadanie: oblicz ile osób zasługuje na podwyżkę:
    =LICZ.JEŻELI(B2:B7; ">"&MAX(B2:B7))

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany.

Witryna wykorzystuje Akismet, aby ograniczyć spam. Dowiedz się więcej jak przetwarzane są dane komentarzy.