Jak szybko sprawdzić płeć

W jednym z wcześniejszych wpisów poruszyłem dość ciekawe zagadnienie, jak przy pomocy korespondencji seryjnej wysłać to samo pismo różniące się kilkoma wyrazami w zależności od płci adresata. Przykładowo wysyłamy to samo pismo, ale dla kobiet będzie ono zatytułowane Szanowna Pani, a dla mężczyzn Szanowny Panie.

Załóżmy, że posiadamy taką oto bazę (z lenistwa, nie wpisywałem całych adresów tj. pominąłem kod pocztowy i miasto)

korespondencja seryjna lista osób

W bazie danych brakuje kolumny płeć. Można oczywiście „dorobić” taką kolumnę i ręcznie wpisywać płeć danej osoby, ale mając bazę np. 1000 klientów nie jest to zbyt wdzięczne zajęcie. Jest jednak prostszy sposób:

Otóż wszystkie żeńskie imiona w języku polskim kończą się na literę a. Natomiast wszystkie męskie imiona kończą się na wszystkie inne litery, tylko nie a. Są drobne wyjątki tj. istnieje kilka męskich imion, które kończą się na a: (Kuba, Kosma, Dyzma, Barnaba i Bonawentura). Wszystkie te imiona z wyjątkiem Kuby można pominąć, gdyż nie są zbyt popularne 😉

Teraz już pewnie wiesz, że wystarczy wpisać do komórki D2 taką oto formułę (i skopiować ją do pozostałych komórek):

=JEŻELI(PRAWY(A2;1)=”a”; „Kobieta”; „Mężczyzna”)

Powyższa formuła sprawdza ostatnią literę imienia i jeśli to jest a, wpisuje do komórki tekst Kobieta w przeciwnym przypadku (jeśli ktoś nie jest kobietą a nie uważa się za gender, to z pewnością jest mężczyzną) wpisuje tekst Mężczyzna. Ta formuła niestety nie uwzględnia naszego nieszczęsnego Kuby uznając go za kobietę. Aby poprawić ten błąd warto użyć zagnieżdżoną funkcję jeżeli:

=JEŻELI(A2=”Kuba”;”Mężczyzna”;JEŻELI(PRAWY(A2;1)=”a”;”Kobieta”;”Mężczyzna”))

A poniższy przykład jest już bardziej dokładny: uwzględnia on wszystkie męskie imiona kończące się na literę a.

=JEŻELI(LUB(A2=”Kuba”; A2=”Barnaba”; A2=”Bonawentura”; A2=”Dyzma”; A2=”Kosma”)=PRAWDA; „Mężczyzna”; JEŻELI(PRAWY(A2;1)=”a”; „Kobieta”; „Mężczyzna”))

Niestety, ale ta reguła z ostatnią literą imienia dotyczy tylko polskojęzycznych imion. W przypadku imion zagranicznych już nie ma tak łatwo – należy mieć bazę imion i skorzystać np. z funkcji WYSZUKAJ.PIONOWO o czym napiszę w najbliższym czasie.

Ten wpis został opublikowany w kategorii sztuczki i oznaczony tagami , , , , , , , , , , , , , . Dodaj zakładkę do bezpośredniego odnośnika.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Witryna wykorzystuje Akismet, aby ograniczyć spam. Dowiedz się więcej jak przetwarzane są dane komentarzy.