Funkcja LICZ.WARUNKI

Jakiś czas temu opisywałem na blogu funkcję LICZ.JEŻELI. Jeśli nie znasz tej funkcji zapoznaj się z tamtym wpisem, gdyż znając funkcję LICZ.JEŻELI łatwiej będzie Tobie opanować funkcję LICZ.WARUNKI.

Załóżmy, że posiadasz następujące dane:

Aby policzyć ile osób w naszej bazie danych ma minimum 40 lat, można skorzystać ze znanej nam już funkcji LICZ.JEŻELI:

=LICZ.JEŻELI(D2:D20; „>=40”)

Aby policzyć ile osób z naszej bazy to kobiety znów skorzystamy z funkcji LICZ.JEŻELI:

=LICZ.JEŻELI(C2:C20; „K”)

Niestety, ale funkcja LICZ.JEŻELI pozwala nam zliczyć komórki, które spełniają tylko jeden warunek (np. ile osób ma odpowiednią liczbę lat, albo ile mamy kobiet). Gdybyśmy chcieli policzyć rekordy, które spełniają jednocześnie kilka warunków to musimy skorzystać z funkcji LICZ.WARUNKI (która jest jakby taką ulepszoną funkcją LICZ.JEŻELI).

Funkcja LICZ.WARUNKI przyjmuje parzystą liczbę argumentów, pierwszy argument to zakres komórek, drugi argument to kryterium jakie ma spełniać danych zakres komórek, trzeci argument to drugi zakres komórek a czwarty argument to kryterium itp. W sumie można za pomocą funkcji LICZ.WARUNKI zdefiniować nawet 127 własnych warunków.

Aby policzyć ile mamy kobiet w wieku minimum 40 lat należy wpisać taką oto funkcję:

=LICZ.WARUNKI(D2:D20;”>=40″; C2:C20;”K”)

Dwa pierwsze argumenty tej funkcji zliczają ile mamy osób 40+, natomiast dwa kolejne argumenty zliczają ile mamy kobiet. Aby dana osoba została „policzona” musi spełniać jednocześnie oba warunki (czyli ta funkcja nie zliczy nam np. kobiet w wieku poniżej 40 lat).

Ten wpis został opublikowany w kategorii funkcje i oznaczony tagami , . Dodaj zakładkę do bezpośredniego odnośnika.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Witryna wykorzystuje Akismet, aby ograniczyć spam. Dowiedz się więcej jak przetwarzane są dane komentarzy.