Excel – jak na podstawie daty obliczyć dzień tygodnia?

Excel bardzo często jest wykorzystywany do tworzenia różnego rodzaju harmonogramów. Tworząc harmonogram wygodnie by było, gdyby oprócz podania daty można było automatycznie na jej podstawie obliczyć dzień tygodnia (bo np. w soboty i niedziele firma jest nieczynna).

Istnieje w Excelu funkcja o nazwie DZIEŃ.TYG, która na podstawie daty zwraca odpowiadający jej dzień tygodnia.

Aby poznać tę funkcję wprowadź do arkusza dane jak na poniższym rysunku

funkcja DZIEŃ.TYG

W komórce B3 wpisz formułę: =DZIEŃ.TYG(A3) i skopiuj tę formułę do komórek B4:B9. Następnie w komórce B14 wpisz formułę: =DZIEŃ.TYG(A14; 2) i skopiuj ją do komórek B15:B20.

Funkcja ta przyjmuje jeden bądź dwa argumenty. Gdy do funkcji DZIEŃ.TYG przekażemy tylko jeden argument jakim jest data (lub komórka zawierającą tę datę) to funkcja zwróci następującą liczbę:

  • 1 – niedziela
  • 2 – poniedziałek
  • 3 – wtorek
  • 4 – środa
  • 5 – czwartek
  • 6 – piątek
  • 7 – sobota

Jednak my jesteśmy przyzwyczajeni, że to poniedziałek (a nie niedziela) jest pierwszym dniem tygodnia. Dlatego warto jest przekazać do funkcji drugi opcjonalny argument jakim jest zwracany typ. Jeśli drugim argumentem tej funkcji będzie liczba 2, to wtedy funkcja będzie zwracała liczbę 1 dla poniedziałku, 2 dla wtorku i tak dalej aż do niedzieli, dla której zwróci liczbę 7.

Mając tak zaprojektowany harmonogram dyżurów można dodatkowo użyć formatowania warunkowego (zaznacz wszystkie komórki w kolumnie B i wprowadź dwie reguły: jedna kolorująca na niebiesko jeśli w komórce jest liczba 6; a druga kolorująca na czerwono, gdy w komórce jest liczba 7). O formatowaniu warunkowym pisałem w notce: Excel – formatowanie warunkowe – wprowadzenie

W niedalekiej przyszłości opiszę na blogu modyfikację ćwiczenia w ten sposób, że usuniemy kolumnę B natomiast daty w kolumnie A będą odpowiednio kolorowane przy użyciu niestandardowej reguły formatowania warunkowego.

Ten wpis został opublikowany w kategorii sztuczki. Dodaj zakładkę do bezpośredniego odnośnika.

1 odpowiedź na Excel – jak na podstawie daty obliczyć dzień tygodnia?

  1. asdfasdf pisze:

    ja osobiście wolę
    =TEKST(„2020-08-27″;”dddd”)
    =TEKST(A3;”dddd”) w przykładzie wyżej

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Witryna wykorzystuje Akismet, aby ograniczyć spam. Dowiedz się więcej jak przetwarzane są dane komentarzy.