Automatyczne tłumaczenie formuł z polskiego do anglojęzycznego Excela i odwrotnie

Czy pracujesz w anglojęzycznym Excelu? Jeśli tak, to pewnie nie raz wkurzała Ciebie taka sytuacja, że znalazłeś jakąś fajną formułę dla polskojęzycznego Excela i musiałeś męczyć się z ręcznym tłumaczeniem nazw wszystkich funkcji.

Przykładowo: kiedyś spłodziłem taką oto fajną funkcję walidującą czy numer PESEL jest poprawny:

=JEŻELI(DŁ(A2)<>11;"pesel musi mieć 11 znakow";JEŻELI((MOD(10-MOD(FRAGMENT.TEKSTU(A2;1;1)*1+FRAGMENT.TEKSTU(A2;2;1)*3+FRAGMENT.TEKSTU(A2;3;1)*7+FRAGMENT.TEKSTU(A2;4;1)*9+FRAGMENT.TEKSTU(A2;5;1)*1+FRAGMENT.TEKSTU(A2;6;1)*3+FRAGMENT.TEKSTU(A2;7;1)*7+FRAGMENT.TEKSTU(A2;8;1)*9+FRAGMENT.TEKSTU(A2;9;1)*1+FRAGMENT.TEKSTU(A2;10;1)*3;10);10))*1<>(FRAGMENT.TEKSTU(A2;11;1)*1);"zla suma kontrolna";"ok"))

Pracując w anglojęzycznej wersji Excela ta formuła będzie wyglądała następująco:

=IF(LEN(A2)<>11;"pesel musi mieć 11 znakow";IF((MOD(10-MOD(MID(A2;1;1)*1+MID(A2;2;1)*3+MID(A2;3;1)*7+MID(A2;4;1)*9+MID(A2;5;1)*1+MID(A2;6;1)*3+MID(A2;7;1)*7+MID(A2;8;1)*9+MID(A2;9;1)*1+MID(A2;10;1)*3;10);10))*1<>(MID(A2;11;1)*1);"zla suma kontrolna";"ok"))

Współczuję Tobie, jeśli musisz ręcznie zamieniać te 11 funkcji FRAGMENT.TEKSTU na funkcję MID, JEŻELI na IF itp. Ale podczas opracowywania zestawienia polskich i angielskich funkcji pomyślałem, że mogę w kilka chwil (czytaj 2 wieczory) napisać prosty konwerter, który automatycznie tłumaczy formuły w obie strony.

Konwerter znajduje się pod adresem: funkcje.officeblog.pl, będę wdzięczny za zgłaszanie wszelkich uwag.

Ten wpis został opublikowany w kategorii funkcje i oznaczony tagami . Dodaj zakładkę do bezpośredniego odnośnika.

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany. Wymagane pola są oznaczone *

Witryna wykorzystuje Akismet, aby ograniczyć spam. Dowiedz się więcej jak przetwarzane są dane komentarzy.