Funkcja LICZ.JEŻELI

Z własnego doświadczenia widzę, że sporo osób „boi się” funkcji LICZ.JEŻELI. A szkoda, gdyż jest to bardzo użyteczna funkcja. W skrócie: zwraca ona nam informację, ile komórek z danego zakresu spełnia określony warunek (np. Ilu mamy Kowalskich w klasie; ile zatrudniamy kobiet; ile osób w grupie ma powyżej 50 lat itp.).

Rozpatrzmy kilka prostych przykładów. Ale zanim to nastąpi, wprowadź przykładowe dane do arkusza, jak na poniższym rysunku.

Pobierz przykład

Funkcja LICZ.JEŻELI przyjmuje dwa argumenty: pierwszy to zakres, a drugi to kryteria. Przykładowo, aby policzyć ile mamy kobiet, należy wpisać funkcję =LICZ.JEŻELI(C2:C9; „K”) (pierwszy argument mówi, że pod analizę bierzemy komórki z zakresu od C2 do C9; argument „K” mówi, że chcemy sprawdzić, czy w danej komórce jest wpisany ciąg znaków K. W naszym przypadku ta funkcja zwróci wartość 4, gdyż w komórkach z zakresu C2:C9 dokładnie 4 razy był wpisany ciąg znaków K.

Jeśli chcielibyśmy sprawdzić, ile mamy w firmie osób noszących nazwisko Ziemba należy wpisać funkcję =LICZ.JEŻELI(B2:B9; „Ziemba”).

A jeśli chcesz sprawdzić, ile osób w firmie ma nazwisko różne niż Ziemba należy użyć funkcji =LICZ.JEŻELI(B2:B9; „<>Ziemba”). Operator <> oznacza „różne od”.

Chcąc policzyć osoby mające powyżej 30 lat należy wpisać taką oto funkcję: =LICZ.JEŻELI(D2:D9; „>30”). Jeśli chcemy policzyć również osoby mające dokładnie 30 lat i więcej, to należy użyć argumentu większe lub równe, czyli nasza funkcja będzie miała postać =LICZ.JEŻELI(D2:D9; „>=30”).

Funkcja LICZ.JEŻELI może służyć również do zliczania dat. Jeśli chcemy policzyć ile osób zatrudniliśmy po 1 kwartale roku 2016 można użyć taką oto funkcję: =LICZ.JEŻELI(E2:E9; „>2015-03-31”).

Funkcja LICZ.JEŻELI ma pewną wadę: otóż zlicza ona komórki tylko według jednego kryterium. Przykładowo za pomocą tej funkcji nie zliczymy ilu mamy pracowników, którzy pracują w Krośnie lub Rzeszowie. Ale w tym przypadku należy zsumować liczby zwracane przez dwie oddzielne funkcje: =LICZ.JEŻELI(F2:F9; „Rzeszów”) + LICZ.JEŻELI(F2:F9; „Krosno”)

 

Ten wpis został opublikowany w kategorii funkcje i oznaczony tagami , , . Dodaj zakładkę do bezpośredniego odnośnika.

2 odpowiedzi na „Funkcja LICZ.JEŻELI

  1. S. Grażyna pisze:

    Stosuję to czasem i też łącze 2 funkcje

    • Damian Daszkiewicz pisze:

      Czasami stosując symbole wieloznaczne można uniknąć łączenia tych dwóch funkcji. Ale temu zagadnieniu poświęcę na blogu nowy wpis

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *