Excel – funkcja sumująca liczby w całej kolumnie

Rozpatrzmy prosty przykład. Otóż postanawiasz w arkuszu Excela wpisywać wydatki. Uproszczony arkusz może wyglądać tak jak ten na poniższym rysunku:

Pojawia się pewien problem: jaką formułę należy wpisać w komórce F1, aby pojawiła się suma wszystkich wydatków. Na chwilę obecną można wpisać =SUMA(C2:C5). Jednak po dopisaniu kilku kolejnych wydatków, trzeba będzie zmienić naszą formułę.

Być może przyjdzie Tobie do głowy pomysł na wpisanie formuły w stylu =SUMA(C2:C1000) (tutaj zakładasz, że nigdy w ciągu miesiąca nie dokonasz więcej niż 999 transakcji). Jednak ten pomysł ma pewną wadę: suma będzie nieprawidłowa, gdyby się okazało, że jednak w danym miesiącu dokonasz ponad 999 transakcji.Jednak można wpisać prostą formułę, która zsumuje wszystkie liczby w kolumnie C. Ma ona postać: =SUMA(C:C). Analogicznie, gdybyś zechciał zsumować wszystkie liczby znajdujące się w piątym wierszu mógłbyś wpisać formułę =SUMA(5:5)

Uwaga: Jeśli sumujesz wszystkie liczby z kolumny C, to nasza formuła nie może się znajdować w kolumnie C, gdyż pojawi się błąd związany z odwołaniem cyklicznym. Chcąc wstawić sumą w tej samej kolumnie można np. skorzystać z tabeli danych.

Ten wpis został opublikowany w kategorii sztuczki i oznaczony tagami , , , . Dodaj zakładkę do bezpośredniego odnośnika.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *